[root@viriya /root] uname -rmsv |
$ lscfg -vp
|
-b Returns the last boot device.
-B Disk Displays a 1 if the IPL code in the ROS on the machine running the
command is capable of booting from the specified disk. Otherwise, the command
displays a 0.
-o Disk Displays either the disk device name or the location depending upon the
value of disk.
-r Displays amount of real memory in kilobytes.
-s Disk Displays disk size in megabytes.
-t Specifies the type of boot. The return values include:
1 Disk boot
3 CD-ROM boot
4 Tape boot
5 Network boot
-T Displays the hardware platform type of the running machine. Machines with
fundamental differences, such as different types of busses, may have
different hardware platform types. For more information see the bosboot
command.
-z Specifies whether the machine hardware is MP-capable (capable of running the
multi-processor kernel and supporting more than one processor). The return
value indicates:
0 The machine is not MP-capable.
1 The machine is MP-capable.
E queste sono le informazioni che ciascuna opzione ha fornito:
[root@viriya /root] bootinfo -t |
$ netscape
|
[root@viriya /root] mv /usr/netscape/communicator/lib433/libc.a /usr/netscape/communicator/lib433/libc.a.bak
|
AIX 4300-11 maintenance
package Recommended maintenance for AIX 4.3.3 The designation 4330-11 indicates that this package updates AIX 4.3.3 from base level (no maintenance level) to maintenance level 11 (4330-11). IBM recommends that all customers install the latest available maintenace package for their AIX release. To determine if AIX 4330-11 is already installed on your system, run the following command: oslevel -r General description This package contains code corrections for the AIX operating system and many related subsystems. Unless otherwise stated, this package is released for all languages. For additional information, refer to the Package information Download and install instructions
Note: IBM recommends that you create a separate file system for /usr/sys/inst.images to prevent the expansion of the /usr file system. For more information, see the Installation tips.
|
Always read the package information. IBM recommends that you create a separate file system for /usr/sys/inst.images to prevent the expansion of the /usr file system. Downloaded fix packages require a significant amount of disk space. By creating a separate file system, you can avoid expanding the /usr file system. Always run the inutoc command to ensure the installation subsystem will recognize the new fix packages you download. The most common installation procedure is to use smit update_all
You may wish to retain this package for future use. When you install additional operating system software you will want to use this package to bring the additional software up to this maintenance level. |
$ oslevel -r
|
System Management ->
System Storage Management (Physical & Logical Storage) ->
Logical Volume Management -> Volume Groups ->
Set Characteristics of a Volume Group ->
Add a Physical Volume to a Volume Group
Volume group name rootvg
Physical volume names hdisk1
Comando risultante: extendvg -f
'rootvg' 'hdisk1'
0516-086 linstallpv: Volume group descriptor area has a bad block. |
System Management ->
System Storage Management (Physical & Logical Storage) ->
File Systems ->
Add / Change / Show / Delete File Systems -> Journaled File Systems ->
Add a Journaled File System -> Add a Standard Journaled File System
Volume group name rootvg
SIZE of file system (in 512-byte blocks)(Num.) 4194304
MOUNT POINT /usr/sys/inst.images
Mount AUTOMATICALLY at system restart? no
PERMISSIONS read/write
Mount OPTIONS
Start Disk Accounting? no
Fragment Size (bytes) 4096
Number of bytes per inode 4096
Allocation Group Size (MBytes) 8
Il valore di 4194304 blocchi di 512 byte equivale a 2 Gbyte. [root@viriya
/root] locale nostr no:n:N [root@viriya /root] echo `locale nostr | awk -F: '{print $1}'` no |
[root@viriya
/root] mount /usr/sys/inst.images [root@viriya /root] df /usr/sys/inst.images Filesystem 512-blocks Free %Used Iused %Iused Mounted on /dev/lv00 4194304 4062552 4% 17 1% /usr/sys/inst.images |
[root@viriya
/root] mount /opt/freeware [root@viriya /root] df -k /opt/freeware Filesystem 1024-blocks Free %Used Iused %Iused Mounted on /dev/lv01 524288 507780 4% 17 1% /opt/freeware |
[root@viriya
/root]
mv rpm.rte /usr/sys/inst.images/ [root@viriya /root] inutoc /usr/sys/inst.images |
[root@viriya
/root]
installp -pacgXd /usr/sys/inst.images rpm.rte [...] FAILURES -------- Filesets listed in this section failed pre-installation verification and will not be installed. Requisite Failures ------------------ SELECTED FILESETS: The following is a list of filesets that you asked to install. They cannot be installed until all of their requisite filesets are also installed. See subsequent lists for details of requisites. rpm.rte 3.0.5.39 # RPM Package Manager MISSING REQUISITES: The following filesets are required by one or more of the selected filesets listed above. They are not currently installed and could not be found on the installation media. bos.rte.libc 5.1.0.0 # Base Level Fileset << End of Failure Section >> [...] |
[root@viriya
/root] installp -pacgXd /usr/sys/inst.images rpm.rte 3.0.5.38 [root@viriya /root] installp -pacgXd /usr/sys/inst.images rpm.rte 3.0.5.37 |
#
installp -pacgXd /usr/sys/inst.images rpm.rte 3.0.5.36 ******************************************************************************* installp PREVIEW: installation will not actually occur. ******************************************************************************* +-----------------------------------------------------------------------------+ Pre-installation Verification... +-----------------------------------------------------------------------------+ Verifying selections...done Verifying requisites...done Results... SUCCESSES --------- Filesets listed in this section passed pre-installation verification and will be installed. Selected Filesets ----------------- rpm.rte 3.0.5.36 # RPM Package Manager << End of Success Section >> FILESET STATISTICS ------------------ 1 Selected to be installed, of which: 1 Passed pre-installation verification ---- 1 Total to be installed RESOURCES --------- Estimated system resource requirements for filesets being installed: (All sizes are in 512-byte blocks) Filesystem Needed Space Free Space / 80 7608 /usr 6176 28280 /var 152 13080 /opt/freeware 56 1015560 ----- -------- ------ TOTAL: 6464 1064528 NOTE: "Needed Space" values are calculated from data available prior to installation. These are the estimated resources required for the entire operation. Further resource checks will be made during installation to verify that these initial estimates are sufficient. ****************************************************************************** End of installp PREVIEW. No apply operation has actually occurred. ****************************************************************************** |
[root@viriya
/root]
installp -acgXd /usr/sys/inst.images rpm.rte 3.0.5.36 [...] ERROR: /opt/freeware exists, but it is not the same directory as /usr/opt/freeware. Correct the condition by linking /opt/freeware and /usr/opt/freeware or by removing /opt/freeware.> instal: Failed while executing the rpm.rte.pre_i script. [...] +-----------------------------------------------------------------------------+ Summaries: +-----------------------------------------------------------------------------+ Installation Summary -------------------- Name Level Part Event Result ------------------------------------------------------------------------------- rpm.rte 3.0.5.36 USR APPLY FAILED rpm.rte 3.0.5.36 USR CLEANUP SUCCESS |
[root@viriya
/root] ln -s /usr/opt/freeware /opt/freeware [root@viriya /root] installp -acgXd /usr/sys/inst.images rpm.rte 3.0.5.36 [...] +-----------------------------------------------------------------------------+ Summaries: +-----------------------------------------------------------------------------+ Installation Summary -------------------- Name Level Part Event Result ------------------------------------------------------------------------------- rpm.rte 3.0.5.36 USR APPLY SUCCESS rpm.rte 3.0.5.36 ROOT APPLY SUCCESS |
[root@viriya
/root] rpm --test --install RPMS/gzip-1.2.4a-7.aix4.3.ppc.rpm [root@viriya /root] rpm --install RPMS/gzip-1.2.4a-7.aix4.3.ppc.rpm [root@viriya /root] which gzip /usr/bin/gzip [root@viriya /root] ls -l /usr/bin/gzip lrwxrwxrwx 1 root system 27 Feb 25 17:45 /usr/bin/gzip -> ../../opt/freeware/bin/gzip |
[root@viriya
/root] cd /usr/sys/inst.images [root@viriya /root] gzip -dc /mnt/cdrom/4330011.tar.gz | tar -vtf - x U455984.bff, 14336 bytes, 28 media blocks. x U461291.bff, 7168 bytes, 14 media blocks. x U466229.bff, 27648 bytes, 54 media blocks. [...] x U485725.bff, 35840 bytes, 70 media blocks. x U485726.bff, 26624 bytes, 52 media blocks. x U485727.bff, 45056 bytes, 88 media blocks. [root@viriya /root] inutoc /usr/sys/inst.images [root@viriya /root] installp -acgXd /usr/sys/inst.images bos.rte.install [...] Installation Summary -------------------- Name Level Part Event Result ------------------------------------------------------------------------------- bos.rte.install 4.3.3.81 USR APPLY SUCCESS bos.rte.install 4.3.3.81 USR COMMIT SUCCESS [root@viriya /root] smit update_all * INPUT device / directory for software [/usr/sys/inst.images] + * INPUT device / directory for software /usr/sys/inst.images * SOFTWARE to update _update_all PREVIEW only? (update operation will NOT occur) no + COMMIT software updates? yes + SAVE replaced files? no + AUTOMATICALLY install requisite software? yes + EXTEND file systems if space needed? yes + VERIFY install and check file sizes? no + DETAILED output? no + |
[root@viriya
/root] oslevel -r 4330-11 [root@viriya /root] shutdown -r now |